I am almost finished assembling my 2 Axis machine and am having issues with the powered USB hub being recognized by my laptop. I am running Windows 10 Home on a HP Stream laptop.

When I run the Executor I get a popup saying the USB hub is not recognized. When I look at my Device Manager it shows the USB hub as Unknown USB Device (Device Descriptor Request Failed). See the aatched screenshot.

Also, the USB hub has 1 of the USB cables with a solid blue light and the other 2 are fast blinking blue lights. I've done some Googling on it and have done the uninstall part, tried t4o update drivers, etc. with no succes. I am using the USB hub provided in the kit which is the RSHTECH RSH-518 model.

Any insight or help would be greatly appreciated!




You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –


  • I figured it out. One of the included kit USB cables was defective. After I switched it out, everything worked as expected.

This reply was deleted.