Filament Skipping

Hi everyone this is my first time posting here. I am noticing an issue with the start of the second pass of a helical wind. On the second pass it tends to space out a good distance from the first pass going from right to left. On the return from left to right everything starts falling into place from there on.

Is there a reason why it does this and is there a way to fix it?

Your help is most appreciated.

You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –


  • I am coming back in this discussion to ask if somoene would agree to share the design parameters and corresponding g-code of a 3-axis no wrap part with angles (helical winding) and no gaps between tapes, like in this video for exemple :

    If you are using 4x-23 and version 4.17 it would be better for me as I work with those but if not I would still take it.

    I would like to try it on my machine, see if it works and if so, work with this specific design to at least be able to build a part in a helical way and try different materials.
    Thank you in advance for your help.
    • Maxime Fournier,

      Can you please tell me what type of computer you have been using to run the X-winder. Please note desktops and laptops are different and also what type of RAM and processor type does it have.

      It is a possibility that the X-Winder program needs to meet certain system requirements in order to operate properly.

      I would gladly share with you files, but I only have the two axis version.

    • Hi Alexander,

      I am using this laptop : Hp probook 640 g1, x64, RAM 16Go, Processor I7 - 4610M - 3GHz - 2 cores with Windows 10 Pro.

      Have you tried diferent computers and found one that seems to have a better compatibility with X-winder program ?

    • Maxime Fournier,

      You have a powerful laptop and yet you have filament displacement still? I have tried on a lenovo desktop that is a weaker than my surface pro 3. The results were bad. After a few email exchanges with Turner Hunt, he revealed to me that he runs his X-winder on Windows 7.

      This leads me to believe that this is a compatability issue with windows 10. However I have yet to try it so I can not confirm this. I will be trying it out this Friday so I will find out. My old computer is weaker than his on RAM, but if it works then we know for certain that it is a compatability issue.

    • Alexander,

      The problem may be due to a delay accumulated from the computer through USB connections, hubs and boards to each motor.

      As each board gives the signal to one motor, if the delay is diferent from one to another, then this could explain gaps between tapes.

      I am thinking about replacing the actual boards with only one which has several inputs, but yes it would require to change a lot of things... Maybe it is an interesting track.

      Did you try the X-winder on Windows 7 ?

    • Hi Maxime Fournier,

      I did try the wind with an old Computer. It is a dell optiplex 745 with a dual core processor and only 2GB of RAM. It has windows 7 ultimate. I still ended up with displacement.

      I went to device manager and turned off the power management on the USB ports so that there is no loss in signal like you mentioned. That still did not work. However I would keep those changes, because it is a possible thing that could interfere.

      In the end I got rid of the M602 and changed all the L602 to L601. The L602 is usually where the gaps occured so I got rid of them and this ended up working. Let me know what diameter in 2 axis you can use so I can share a g-code in the format that I fixed it in, so that you can try it out.

    • Hi Alexander,

      Thanks for your feedback, I would be happy to have a look to your g-code and try it. I usually work with a 3,268 inches diameter (I can go up to 8 inches) and a 8 inches length.

  • Is anyone still experiencing filament displacement in the L602 returns?

    • Hi Alexander, hi everyone,

      I am joining the discussion because I am experiencing the same kind of problem. I am working with a 4x-23 in 3-axis mode and version 4.17 of the software. I notice a variable gap for each pass (a bit more marked in L602 returns) even with very low mandrel rotation speed (tested from 5 to 20 rpm). The same gaps scheme appears regardless of the mandrel rotation speed or the DH path. However, it widely depends on the winding angle.

      The best result I got is for a 75° winding angle and there are still large gaps... (see picture). For any other winding angle values far enough from 75°, gaps are terrifically large. I do not see any error in the G-code and I do not understand why the first two passes from right to left are well deposed but not the other.


    • Hi Maxime Fournier,

      I am glad to see I am not the only one with these issues. I just recently I emailed the X-Winder crew about this as I am fed up with it. It has been a year since I made this post and I have yet to see any updates to the software.

      I too still use version 4.17 as version 4.20 had an issue where it would slam into the limit switch often. It wasnt a hard slam, but it would ignore the Z offset and set itself in a position that would slam against the limit switch.

      The software is indeed broken and I want to have perfectly wound tubes. It defeats the purpose of having this awesome machine if it can not wind properly.

This reply was deleted.