Community

Filament Skipping

Hi everyone this is my first time posting here. I am noticing an issue with the start of the second pass of a helical wind. On the second pass it tends to space out a good distance from the first pass going from right to left. On the return from left to right everything starts falling into place from there on.

Is there a reason why it does this and is there a way to fix it?

Your help is most appreciated.

You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –

Replies

  • Is anyone still experiencing filament displacement in the L602 returns?

    • Hi Alexander, hi everyone,

      I am joining the discussion because I am experiencing the same kind of problem. I am working with a 4x-23 in 3-axis mode and version 4.17 of the software. I notice a variable gap for each pass (a bit more marked in L602 returns) even with very low mandrel rotation speed (tested from 5 to 20 rpm). The same gaps scheme appears regardless of the mandrel rotation speed or the DH path. However, it widely depends on the winding angle.

      The best result I got is for a 75° winding angle and there are still large gaps... (see picture). For any other winding angle values far enough from 75°, gaps are terrifically large. I do not see any error in the G-code and I do not understand why the first two passes from right to left are well deposed but not the other.

      2704964358?profile=RESIZE_930x

    • Hi Maxime Fournier,

      I am glad to see I am not the only one with these issues. I just recently I emailed the X-Winder crew about this as I am fed up with it. It has been a year since I made this post and I have yet to see any updates to the software.

      I too still use version 4.17 as version 4.20 had an issue where it would slam into the limit switch often. It wasnt a hard slam, but it would ignore the Z offset and set itself in a position that would slam against the limit switch.

      The software is indeed broken and I want to have perfectly wound tubes. It defeats the purpose of having this awesome machine if it can not wind properly.

  • I wound another tube today with the suggested 20RPM mandrel speed and although I got a better finish, there are still some minor gaps visible. It appears it still needs to wind even slower just to get a no gap finish. 

    Hopefully Turner Hunt will fix this soon.

  • I forgot to post a picture of the tube

    701172075?profile=RESIZE_930x

  • I am having the same issue. Were you able to resolve it? I am using the latest software., V4.20319173250?profile=RESIZE_710x

    • Hi Ben,

      I have yet to fix this issue. At this point I am convinced its a source code issue. The X-Winder is not executing the G-code properly. According to Turner Hunt, the stepper controller has an 8ms delay and this is what causes it. 

      I dont see that being the issue as one of his four axis, winding in 3 axis mode videos, has pretty much the same G-code with extra commands and winds without any gaps.

      Unfortunately all we can do is just wait until he fixes this issue. Try winding slow, if it is that 8ms delay, maybe that will give you getter results, but lets face it, that will take forever lol.

    • I agree with you Alexander, it must be an error in the g-code execution. I have the same issue with my 4x-34 (in 3-axis mode) and 4.17 version (my dh linear control board is not recognized by the 4.20 software... but that's an another problem). The g-code is fine but there is gaps and even filament crossing between passes... I hope that will be solved soon!

    • William, I am shocked to even hear that the 4X-34 in 3 axis mode is even producing these gaps and cross pass of the filament. 

      Tomorrow I am going to record the executor executing the g-code’s helical passes and see if the placement of the filament is on the correct areas. 

      One thing I have noticed is that majority of the L601 passes are on the correct areas for adjacent placement. The L602 however, is where those gaps and cross passing occur.

    • Turners response to remedy the issue...

      ”We've run your g-code file on a 3.2" mandrel at 40 RPM and 20 RPM, and we added a full revolution at the far end on only the first pass (see settings).

      At 40 RPM we see the same gaping as you describe. At 20 RPM we do not. Basically run the machine slower. “
      Will try that tonight or tomorrow.
      He did go on to explain the whole 8ms delay and that they are going to work on the software.
This reply was deleted.