NEMA23 Motors not working

We recently bought the 4X-23 model and now have the problem that the 2 NEMA23 for carriage and mandrel cannot be controlled. DH works perfectly fine. All axis controllers have been tested for all motors but problem remained. Hence, X-Winder setup is not possible as software tries to seek axis limits but carriage does not move at all. Instead, even when tried to operate manually, NEMA23 only start hissing/buzzing with different pitch and volume, depending on how often a button for movement is clicked. 

Powered USB-Hub which is delivered by X-Winder is used as well as the original power supply. All control boards are recognized by the software. Help in the software states version 4.17 for designer and 4.16 for executor. PC is running on Win10. I read through the forum and tried almost everything what I can do without administrator-permission as it is a company-PC.

Does anyone have some ideas to solve my problem? Thanks a lot!

You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –


  • Hello all,

    we played around a little and tried quite everything to get the motors running. The more we tried the more it seemed to be a hardware issue so finally we ended up partially dissasembling the motors. After simply removing the endplate of one motor we gave it a try and the motor was running. It turned out that the "teeth" of stator and rotor interlocked with each other near one coil like two gears. Obviously, removing the endplate resulted in enough clearance to get the motor up and running and luckily reassembly didn't change anything to that.

    Unfortunately we do not have the guarantee that this interlocking does not happen again, but for now both NEMA23 are running again and I will keep on monitoring the situation. If it happens again frequently we for sure need to find another solution than disassembly of the motors.

    I'll keep you updated how things are running. ;) 
This reply was deleted.