Winding process stops in G-code line 35

Hi all,

We have start working recently with our new X-Winder 4-Axis Model 4X-23. We are trying to manufacture next configurartion:

10833297265?profile=RESIZE_710xThe machine looks run OK during "Home", "Manual" and "Trace" functions.

But, when we run "Build" function process stops at G-code line 35, after the DH moves towards the winding start position. Then mandrel motor keeps rotating at winding speed but neither carriage nor DH head do any other movement. DH liner and rotaring motors starts vibrating slighly and makes a little noise. Carriage motor doesn´t do anything.

This is the our line 35 text:

10833310092?profile=RESIZE_710xDoes anyone has the same problem? Any idea how can we solve it?

Best regards,


You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –


  • If I understood your problem correctly, we could have had similar issues with our X-Winder. We also tried various PCs, both laptops and desktop PCs. We finally found the most probable root cause in the energy saving settings of the PCs.

    So we turned off really all of the energy settings and had no further problems with the machine movement.

    Hope that helps ;) 

    • Hi, I got one software version 4.20 which doesn't have the G-code line 35 issue. Have you got some other issues like, during building, the DH, carriage and mandrel work well, but DL moves inaccurately, or without following the code? The motor for DL turns not smoothly. Do you think it could be a motor problem or software?


    • We had various issues before changing the energy settings of the PC and as mentioned it turned out that it neither was software related nor hardware related.

      We turned off all energy saving options and particularly the energy saving options for the USB ports and connected all axis controllers separately to the PC. That helped us to get a proper machine behaviour.

      The energy saving options can be found in the Power Options in the Control Panel of the PC, see in the pics. :) EditPowerPlan_Dialog.png


  • Yes, I could solving the problem by using a diferent computer but I really don´t know where was the problem

  • Hi, have you solved this problem? I got the same issue.

This reply was deleted.