Community

4-Axis Set-up

Hi all,

I'm currently trying to set-up a trial run of the 4X-23. I've successfully run the 2x demo G-script using the 2X settings, however, I'm having issues when trialling the 4X demo script. When running the 4X script the machine correctly re-positions itself to the limit switches then proceeds to attempt to withdraw the linear carriage head (which is already fully retracted). This causes compression of the carriage head and audible clicking noise from the motor. 

Has anyone else encountered this issue when running the demo script? The limit switches are working correctly. 

All ideas welcomed. 

 

You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –

Replies

  • Hi Henry,

    I encountered a similar problem when I set up my machine.  I didnt run that demo scrpt however I would check the "head offset" number. It should be set to the distance you want the front roller from the mandrel to avoid it hitting. Keep this number as small as possible as it helps keep the filament tight during winding and prevents unnesseary slipping on the mandrel.

    3057354816?profile=RESIZE_710xMe being me I originally thought this setting was a mesurement from the centreline of the mandrel, however it does a bit more math than I would like and interprets this number as a distance from the diameter of the mandrel.
    I found that there is no endstop overides in place so if your code says "move carrige backwards 200mm" it will try regardless of your endstop being triggered.
    So my suggestion is check the setup, it might not be this but it could be something similar.
    hope this helps

    • Hi Aaron, 

      Thanks for the advice! It was in the end partly the setup dimensions and partly the DH belt assembly. 

This reply was deleted.