Community

Control Boards Not Connected

We recently upgraded the PC our X-Winder was connected to, and we're running into an issue.  Whenever we try to run Executor, it throws an error stating some control boards aren't attached. 

We have a 2 axis setup.  As far as I know, everything is setup the exact same as on the old PC.  It was previously on Windows 7, now on Windows 10.  We also noticed the power supply was weak, and thought upgrading it would help, but no luck.

The mandrel and carriage axes are connected, and we didn't need anything else on the old system.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Any input is appriciated!

You need to be a member of X-Winder to add comments!

Join X-Winder

Email me when people reply –

Replies

  • Ok.  I have been figuring this out over the last few days (if you haven't figured it out already). 

    My windows 10 laptop recognised all the boards just fine and was able to run, so I knew there was no issue with the controllers.

    I then setup my CNC computer (running windows 7) to do the same....and one board did not work for some reason.  I tried uninstalling/reinstalling/updating windows etc. etc.

    After a few hours of mucking around I found in device manager it came up with the one board in "other devices" (it looked something like "1010_1").  I went to properties of that device and clicked on update driver (search automatically from internet).  It found the usb driver and everything worked fine.

    If this helps fanstastic...if not then back to the drawing board.

  • Very strange... I have not encountered this problem yet with my machine.  Have you tried uninstalling/reinstalling the software? Something isn't talking properly and it sounds like it's the software.

    • I've tried

      • Uninstalling, rebooting, then reinstalling
      • Running as admin
      • Running from an admin account
      • Installing the software on a different Win10 PC

      When looking in Device Manager, I select "Show Hidden Devices", but nothing sticks out.  Any idea what the name of the driver is that I need to install/update?

  • We are getting the same thing.  It'a a new laptop but still Windows 7.  And yes, we checked the device manager and they are working.  In fact, when you go into settings, you can operate the motors in one of the dialog boxes.  Software problem?

  • Hi,

    Are your control boards showing up as devices in Windows device manager? If they are all there then there is an issue else where.  If they do not show up then there is a problem with your usb connections.

This reply was deleted.